Linux Magazine Forum
Gennaio 16, 2018, 08:28:06 am *
Benvenuto! Accedi o registrati.
Hai dimenticato l'e-mail di attivazione?
 
   Indice   programmazione windows internet videogame Aiuto Ricerca Agenda Accedi Registrati  
Pagine: [1] 2   Vai giù
  Stampa  
Autore Discussione: server apache2 non funziona correttamente  (Letto 240 volte)
0 utenti e 1 Utente non registrato stanno visualizzando questa discussione.
jambolo
Sr. Member
****

Karma: +3/-3
Scollegato Scollegato

Messaggi: 380


W l'Open Soruce mi ha rivoluzionato la vita


Mostra profilo
« inserita:: Gennaio 04, 2018, 11:36:33 am »

Buon anno a tutta la comunità,
L'inizio anno non è iniziato benissimo, avevo installato ancora l'estate scorsa phpBB per creare un mini forum che funzionava benissimo fino a fine dicembre, poi durante un aggiornamento mi è saltato tutto

sia da localhost:8080 che da ip esterno sembrerebbe che il server apache non funzioni,

mentre controllando da terminale il servizio apache2 è in funzione
Codice:
gianluca-pc1:/home/jambolo # systemctl status apache2.service
● apache2.service - The Apache Webserver
   Loaded: loaded (/usr/lib/systemd/system/apache2.service; enabled; vendor preset: disabled)
   Active: active (running) since gio 2018-01-04 11:19:07 CET; 9min ago
 Main PID: 28078 (/usr/sbin/httpd)
   Status: "Total requests: 0; Current requests/sec: 0; Current traffic:   0 B/sec"
    Tasks: 8
   CGroup: /system.slice/apache2.service
           ├─ 2479 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconf...
           ├─ 2497 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconf...
           ├─28078 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconf...
           ├─28087 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconf...
           ├─28088 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconf...
           ├─28089 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconf...
           ├─28090 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconf...
           └─28091 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconf...

A questo punto non riesco a capire che cosa sia successo e perché non funzioni più
grazie in anticipo
Registrato

Sistemi OP. preferiti fino ad oggi:
Win2k     |   Suse Linux 9.2   |   Opensuse 13.1 |   LinuxMint 7 - 9 (fino ad ora quelle più stabili nel tempo)
- -
Peccato che sono uno tra i pochi ad utilizzare FirefoxOS, e mozilla non assiste sugli aggiornamenti.
michele.p
Administrator
Hero Member
*****

Karma: +72/-46
Scollegato Scollegato

Messaggi: 9318



Mostra profilo
« Risposta #1 inserita:: Gennaio 04, 2018, 02:24:27 pm »

Curiosità mia prima di riportare qualche possibile risposta: perché utilizzi l'indirizzo localhost:8080?
L'hai cambiato? Lo chiedo perché di default Apache utilizza la porta 80 quindi sarebbe sufficiente con un browser collegarsi all'indirizzo localhost.

Detto ciò, se provi con l'indirizzo:

http://127.0.0.1:8080

funziona?
Registrato

jambolo
Sr. Member
****

Karma: +3/-3
Scollegato Scollegato

Messaggi: 380


W l'Open Soruce mi ha rivoluzionato la vita


Mostra profilo
« Risposta #2 inserita:: Gennaio 04, 2018, 06:02:20 pm »

sulla porta 80 usata di default c'è un altro pc, quindi per non avere conflitti sul router ho dovuto utilizzare la porta 8080 per poter indirizzare dal router al pc in questione, solo per questo ho utilizzato su Yast Server HTTP tutti gli indirizzi su porta 8080.

Quando faccio 127.0.0.1:8080
o indirizzo_esterno:8080

sul pc salta fuori
Citazione
Accesso negato!

Non disponi dei permessi necessari per accedere alla directory richiesta oppure non esiste il documento indice.

Se pensi che questo sia un errore del server, per favore contatta il webmaster.
Error 403
127.0.0.1
Apache

Ora visto che mi dice che i permessi non li ho, ho provato a dare il comando
chmod 777/srv/www/htdocs
poi ho dato lo stesso comando anche ai file contenuti in htdocs, che è la directory di default su opensuse
ed anche alla directory che contiene il forum.

Purtroppo il risultato non cambia...

se invece faccio:
localhost:8080
mi dice  "SONO OPERATIVO"
perchè la pagine web  che ho creato come index.html ha questa frase.

ho provato a disattivare anche il firewall ma la situazione rimane sempre la stessa, francamente non riesco a capire cosa abbia fatto l'update per provocarmi questo, visto che a parte la porta il resto era tutto di default.
« Ultima modifica: Gennaio 04, 2018, 06:14:18 pm da jambolo » Registrato

Sistemi OP. preferiti fino ad oggi:
Win2k     |   Suse Linux 9.2   |   Opensuse 13.1 |   LinuxMint 7 - 9 (fino ad ora quelle più stabili nel tempo)
- -
Peccato che sono uno tra i pochi ad utilizzare FirefoxOS, e mozilla non assiste sugli aggiornamenti.
michele.p
Administrator
Hero Member
*****

Karma: +72/-46
Scollegato Scollegato

Messaggi: 9318



Mostra profilo
« Risposta #3 inserita:: Gennaio 04, 2018, 07:20:14 pm »

Uhm, non è che, per caso, nell'aggiornamento si è avuto un cambio dell'utente e/o gruppo che può accedere?

Il server vedo che è installato /srv, allora con il comando ls verifica utente e gruppo di /srv (ad esempio con ls -l /), quindi di /srv/www (con ls -l /srv/www) e anche di /srv/www/htdocs.
Registrato

jambolo
Sr. Member
****

Karma: +3/-3
Scollegato Scollegato

Messaggi: 380


W l'Open Soruce mi ha rivoluzionato la vita


Mostra profilo
« Risposta #4 inserita:: Gennaio 04, 2018, 10:50:52 pm »

la cartella /srv/ e le sue sotto cartelle sono sempre state di proprieta' di root
Codice:
jambolo@gianluca-pc1:~> ls -l /srv/www/
totale 16
drwxr-xr-x 2 root root 4096 16 dic 19.21 cgi-bin
drwxr-xr-x 2 root root 4096 18 mar  2017 fcgi-bin
drwxrwxrwx 5 root root 4096  3 gen 09.54 htdocs
drwxr-xr-x 2 root root 4096 18 mar  2017 perl-lib
jambolo@gianluca-pc1:~> ls -l /srv/www/htdocs/
totale 36
-rwxrwxrwx  1 root root  302 13 mar  2006 favicon.ico
drwxrwxrwx 19 root root 4096 17 set 11.46 forum
drwxrwxrwx  2 root root 4096 16 ago 15.30 gif
-rwxrwxrwx  1 root root  126  2 ago 09.22 index.html
-rwxrwxrwx  1 root root   45 11 giu  2007 index.html.rpmnew
-rwxrwxrwx  1 root root 2356  7 ago 15.34 info2html.css
-rwxrwxrwx  1 root root   20  1 ago 14.27 info.php
drwxrwxrwx  8 root root 4096  1 gen 09.21 phpMyAdmin
-rwxrwxrwx  1 root root   26 21 set 16.15 robots.txt
l'utente jambolo fa parte dei gruppi www,floppy,video,users,cdrom
Registrato

Sistemi OP. preferiti fino ad oggi:
Win2k     |   Suse Linux 9.2   |   Opensuse 13.1 |   LinuxMint 7 - 9 (fino ad ora quelle più stabili nel tempo)
- -
Peccato che sono uno tra i pochi ad utilizzare FirefoxOS, e mozilla non assiste sugli aggiornamenti.
michele.p
Administrator
Hero Member
*****

Karma: +72/-46
Scollegato Scollegato

Messaggi: 9318



Mostra profilo
« Risposta #5 inserita:: Gennaio 04, 2018, 11:30:06 pm »

Occorre vedere il server Apache con quale utente e gruppo "lancia".

Ora non sono su una OpenSUSE, ma cosa riporta il file:

/etc/apache2/uid.conf

...se c'è, sto andando a memoria. :-P
Registrato

jambolo
Sr. Member
****

Karma: +3/-3
Scollegato Scollegato

Messaggi: 380


W l'Open Soruce mi ha rivoluzionato la vita


Mostra profilo
« Risposta #6 inserita:: Gennaio 05, 2018, 08:42:09 am »

Buona memoria :-D, il suo contenuto è:

User wwwrun
Group www
Registrato

Sistemi OP. preferiti fino ad oggi:
Win2k     |   Suse Linux 9.2   |   Opensuse 13.1 |   LinuxMint 7 - 9 (fino ad ora quelle più stabili nel tempo)
- -
Peccato che sono uno tra i pochi ad utilizzare FirefoxOS, e mozilla non assiste sugli aggiornamenti.
michele.p
Administrator
Hero Member
*****

Karma: +72/-46
Scollegato Scollegato

Messaggi: 9318



Mostra profilo
« Risposta #7 inserita:: Gennaio 05, 2018, 03:23:24 pm »

Ecco, abbiamos coperto l'inghippo. Apache lancia con gruppo/utente diverso da quello delle cartelle.
Prova a fare così, nel file /etc/group aggiungi l'utente root al gruppo di Apache, anche se io preferisco un'altra soluzione.
Intanto iniziamo a vedere se l'aggiunta di root al gruppo (www) del web server da i suoi frutti.
Registrato

jambolo
Sr. Member
****

Karma: +3/-3
Scollegato Scollegato

Messaggi: 380


W l'Open Soruce mi ha rivoluzionato la vita


Mostra profilo
« Risposta #8 inserita:: Gennaio 05, 2018, 04:08:12 pm »

di file group in /etc/ ce ne sono 3
c'è :group ho cambiato la riga
     www:x:8:jambolo,root

c'è : group-  ho cambiato la riga
     www:x:8:jambolo,root

c'è group.YaST2save che non conteneva nulla in www:x:8:   l'ho cambiato con
    www:x:8:jambolo,root

però non è cambiato nulla
Registrato

Sistemi OP. preferiti fino ad oggi:
Win2k     |   Suse Linux 9.2   |   Opensuse 13.1 |   LinuxMint 7 - 9 (fino ad ora quelle più stabili nel tempo)
- -
Peccato che sono uno tra i pochi ad utilizzare FirefoxOS, e mozilla non assiste sugli aggiornamenti.
michele.p
Administrator
Hero Member
*****

Karma: +72/-46
Scollegato Scollegato

Messaggi: 9318



Mostra profilo
« Risposta #9 inserita:: Gennaio 05, 2018, 04:24:40 pm »

Allora fai così, rimetti tutto come era prima: rimuovi utente e root da "www" in tutti ii file che hai modificato e dai
questo comando:

chown -R wwwrun:www /srv/www

Ora dovrebbe funzionare.

Registrato

jambolo
Sr. Member
****

Karma: +3/-3
Scollegato Scollegato

Messaggi: 380


W l'Open Soruce mi ha rivoluzionato la vita


Mostra profilo
« Risposta #10 inserita:: Gennaio 05, 2018, 04:53:56 pm »

No non funzia! addirittura ora anche localhost:8080 mi da accesso negato
Registrato

Sistemi OP. preferiti fino ad oggi:
Win2k     |   Suse Linux 9.2   |   Opensuse 13.1 |   LinuxMint 7 - 9 (fino ad ora quelle più stabili nel tempo)
- -
Peccato che sono uno tra i pochi ad utilizzare FirefoxOS, e mozilla non assiste sugli aggiornamenti.
michele.p
Administrator
Hero Member
*****

Karma: +72/-46
Scollegato Scollegato

Messaggi: 9318



Mostra profilo
« Risposta #11 inserita:: Gennaio 05, 2018, 05:00:41 pm »

Ma se dai il comando:

ls -l /srv/www/

gruppo e utente son stati cambiati oppure sono ancora root, root?
Registrato

jambolo
Sr. Member
****

Karma: +3/-3
Scollegato Scollegato

Messaggi: 380


W l'Open Soruce mi ha rivoluzionato la vita


Mostra profilo
« Risposta #12 inserita:: Gennaio 05, 2018, 05:16:09 pm »

sono cambiati:
Codice:
ls -l /srv/www/
totale 16
drwxr-xr-x 2 wwwrun www 4096 16 dic 19.21 cgi-bin
drwxr-xr-x 2 wwwrun www 4096 18 mar  2017 fcgi-bin
drwxrwxrwx 5 wwwrun www 4096  3 gen 09.54 htdocs
drwxr-xr-x 2 wwwrun www 4096 18 mar  2017 perl-li
Registrato

Sistemi OP. preferiti fino ad oggi:
Win2k     |   Suse Linux 9.2   |   Opensuse 13.1 |   LinuxMint 7 - 9 (fino ad ora quelle più stabili nel tempo)
- -
Peccato che sono uno tra i pochi ad utilizzare FirefoxOS, e mozilla non assiste sugli aggiornamenti.
jambolo
Sr. Member
****

Karma: +3/-3
Scollegato Scollegato

Messaggi: 380


W l'Open Soruce mi ha rivoluzionato la vita


Mostra profilo
« Risposta #13 inserita:: Gennaio 05, 2018, 05:25:16 pm »

ho provato a lanciare il comando :
Codice:
systemctl status apache2.service -l
● apache2.service - The Apache Webserver
   Loaded: loaded (/usr/lib/systemd/system/apache2.service; enabled; vendor preset: disabled)
   Active: active (running) since ven 2018-01-05 17:21:23 CET; 58s ago
  Process: 6880 ExecStop=/usr/sbin/start_apache2 -DSYSTEMD -DFOREGROUND -k graceful-stop (code=exited, status=0/SUCCESS)
 Main PID: 6895 (/usr/sbin/httpd)
   Status: "Total requests: 0; Current requests/sec: 0; Current traffic:   0 B/sec"
    Tasks: 7
   CGroup: /system.slice/apache2.service
           ├─6895 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -DSSL -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTEMD -DFOREGROUND -k start
           ├─6904 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -DSSL -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTEMD -DFOREGROUND -k start
           ├─6906 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -DSSL -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTEMD -DFOREGROUND -k start
           ├─6907 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -DSSL -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTEMD -DFOREGROUND -k start
           ├─6909 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -DSSL -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTEMD -DFOREGROUND -k start
           ├─6910 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -DSSL -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTEMD -DFOREGROUND -k start
           └─6946 /usr/sbin/httpd-prefork -DSYSCONFIG -Dinst_server -DSSL -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -DSYSTEMD -DFOREGROUND -k start

gen 05 17:21:23 gianluca-pc1.fritz.box systemd[1]: Starting The Apache Webserver...
gen 05 17:21:23 gianluca-pc1.fritz.box start_apache2[6895]: [Fri Jan 05 17:21:23.398507 2018] [alias:warn] [pid 6895] AH00671: The ScriptAlias directive in /etc/apache2/conf.d/mod_perl.conf at line 14 will probably never match because it overlaps an earlier Alias.
gen 05 17:21:23 gianluca-pc1.fritz.box start_apache2[6895]: [Fri Jan 05 17:21:23.398886 2018] [alias:warn] [pid 6895] AH00671: The ScriptAlias directive in /etc/apache2/conf.d/mod_perl.conf at line 22 will probably never match because it overlaps an earlier Alias.
gen 05 17:21:23 gianluca-pc1.fritz.box start_apache2[6895]: [Fri Jan 05 17:21:23.399090 2018] [alias:warn] [pid 6895] AH00671: The Alias directive in /etc/apache2/conf.d/phpMyAdmin.conf at line 1 will probably never match because it overlaps an earlier Alias.
gen 05 17:21:23 gianluca-pc1.fritz.box start_apache2[6895]: [Fri Jan 05 17:21:23.399273 2018] [alias:warn] [pid 6895] AH00671: The Alias directive in /etc/apache2/conf.d/phpMyAdmin.conf at line 2 will probably never match because it overlaps an earlier Alias.
gen 05 17:21:23 gianluca-pc1.fritz.box systemd[1]: Started The Apache Webserver.
non so se può esserti utile. Che?!?
Registrato

Sistemi OP. preferiti fino ad oggi:
Win2k     |   Suse Linux 9.2   |   Opensuse 13.1 |   LinuxMint 7 - 9 (fino ad ora quelle più stabili nel tempo)
- -
Peccato che sono uno tra i pochi ad utilizzare FirefoxOS, e mozilla non assiste sugli aggiornamenti.
michele.p
Administrator
Hero Member
*****

Karma: +72/-46
Scollegato Scollegato

Messaggi: 9318



Mostra profilo
« Risposta #14 inserita:: Gennaio 05, 2018, 06:05:47 pm »

Ma per caso hai il modulo SELinux attivato? Cosa riporta il comando:

sestatus

Registrato

Pagine: [1] 2   Vai su
  Stampa  
 
Vai a: